De:JOSM and Plugin

Aus OpenSeaMap-dev
Wechseln zu: Navigation, Suche


Sprachen: Deutsch English


Anmelden   Editor-Fenster   Seezeichen barbeiten   Seezeichen eintragen   Häfen eintragen    

JOSM ist ein mächtiges Werkzeug, mit dem alle Elemente in der Karte metergenau bearbeitet werden können.

Ein Plugin und mehrere Vorlagen helfen Dir beim Erfassen von nautischer Information. Über eine grafische Oberfläche kannst Du alle für ein Objekt erforderlichen Daten aus Listen und Grafiken auswählen oder in spezielle Felder eingeben. Es werden nur Auswahlen angeboten, die für ein bestimmtes Objekt auch Sinn machen. Einige Eingaben werden vor dem Speichern zusätzlich auf Sinnhaftigkeit geprüft.

Inhaltsverzeichnis

Video Tutorials

Installation

1. installiere JOSM

Der JOSM-Editor wird von OpenStreetMap heruntergeladen:

für Windows
für MAC OS X
Linux Anwender benutzen ihren Package-Manager
(thumbnail)
Editor installieren
2. installiere den SeaMapEditor

Der SeaMap-Editor wird im Menü "Bearbeiten > Enstellungen" installiert:

wähle im Menu "Bearbeiten" den Punkt "Einstellungen"
wähle links das Icon "Plugin" ("Steckdose", 5. Icon von oben)
scrolle nach unten bis zum "SeaMap-Editor" und setze ein Häckchen
(thumbnail)
Icons installieren
3. installiere die SeaMap-Icons

Damit die Seezeichen in JOSM auch angezeigt werden musst Du sie einmalig aktivieren:

wähle im Menu "Bearbeiten" den Punkt "Einstellungen"
wähle links das Icon "Karten-Projektion" ("Kartengitter", 3. Icon von oben)
wähle oben den Reiter "Kartenstile"
markiere in der Liste den Eintrag "OpenSeaMap"
kopiere den Eintrag mit dem blauen Pfeil in die rechte Liste
(thumbnail)
Vorlage "Hafen" installieren
4. aktiviere die Vorlage "Hafen"

Die Vorlage "Hafen" erleichtert die Erfassung von Seehäfen, Fischerhäfen, Marinas und Ankerplätzen. Mit einfachen Klicks können alle wichtigen Informationen zusammengestellt werden. Auch Hafenanlagen, vom Kran über den Hafenmeister bis zur Altölsammelstelle stehen über Vorlagen zur Auswahl. Alle anderen Kartenelemente lassen sich ebenfalls über benutzerführende Vorlagen eingeben.

wähle im Menu "Bearbeiten" den Punkt "Einstellungen"
wähle links das Icon "Karten-Projektion" ("Kartengitter", 3. Icon von oben)
wähle oben den Reiter "Objektvorlagen"
markiere in der Liste den Eintrag "Hafen"
kopiere den Eintrag mit dem blauen Pfeil in die rechte Liste
(thumbnail)
Remote einschalten
5. aktiviere "Remote Control"

Damit kommst Du mit einem Klick in die Karte direkt in den Editor:

wähle im Menu "Bearbeiten" den Punkt "Einstellungen"
wähle links das Icon "Fernsteuerung" (9. Icon von oben)
setze ein Häckchen bei "Fernsteuerung aktivieren"

Damit das nachher aus der Karte funktioniert, muss JOSM vorher gestartet sein.

Wenn du alle Einstellungen gemacht hast:

klicke "OK", und starte JOSM neu, damit das Plugin fertig installiert wird.

SeaMap-Editor und Vorlagen

(thumbnail)
Editor starten

Du findest den SeaMap-Editor im Menü "Werkzeuge > Seamap-Editor".
Alle Werkzeuge zum Bearbeiten von Seezeichen und anderer nautischer Information sind automatisch integriert und konfiguriert.

Derzeit können alle Tonnen und Baken in IALA-A und IALA-B eingetragen und editiert werden. Ebenso alle Leuchtfeuer und Landmarken.

Die Vorlagen findest Du im Menü"Vorlagen". Über die Vorlagen lassen sich alle Objekte und deren Eigenschaften aus der INT-1 - auch "Seekarte Null" genannt - eingetragen werden

Luftbilder

(thumbnail)
Luftbilder als Hintergrund

Luftbilder können über das Menü Hintergrund eingebunden und angezeigt werden.
Für viele Orte dieser Welt stehen hochauflösende Luftbilder von Bing und Yahoo zur Verfügung. Damit ist es einfach, Umrisse genau abzuzeichnen. Einige Länder haben eigene Luftbilder freigegeben. Bei der Arbeit an Küsten, in Flussmündungen und Schären sind auch Infrarotbilder sehr hilfreich.

Leider gibt es für viele Küsten noch keine brauchbaren Luftbilder.
Die Bilder von Google können aus lizenzrechtlichen Gründen leider nicht benutzt werden.
Hier hilft nur Ortskenntnis und ein eigener GPS-Track.

Anleitung für JOSM

ausführliche Hilfe und Beschreibung für JOSM

Anmeldung

OE-create new account.png

Du musst angemeldet sein, um Daten eingeben oder ändern zu können.

Dazu brauchst Du ein OSM-Benutzerkonto. Das Benutzerkonto von OpenStreetmap gilt auch für OpenSeaMap und umgekehrt. Benutzername und Passwort sind für OpenSeaMap und Openstreetmap identisch.

Nach dem ersten Anmelden merkt sich Dein Computer Deinen Benutzernamen und Dein Passwort. Damit Du Dich auch auf einem anderen Computer anmelden kannst (z.B. Im Internetcafe im Ausland), solltes Du die Anmeldedaten irgendwo aufschreiben und auf Törn mitnehmen.

Wenn Du noch kein Benutzerkonto bei OpenSeaMap oder bei Openstreetmap hast, klicke im Anmelde-Dialog auf den Link "Benutzerkonto erstellen". Gib 2x Deine Mailadresse ein. Diese wird nicht öffentlich angezeigt. Sie dient ausschliesslich für die Anmeldebestätigung und für Kontaktaufnahmen über ein Web-Formular. Wähle einen Benutzernamen, beispielsweise "Vorname Nachname". Falls der Name schon vergeben ist, versuche eine Variante (z.B. eine Zahl dranhängen). Wähle ein Passwort und gib es 2x ein. Das Passwort muss mindestens 8 Zeichen lang sein. Wähle ein Passwort, das Du nicht anderswo für sicherheitsrelevante Anwendungen verwendest, denn es wird unverschlüsselt übertragen.

Mit dem Klick auf "Registrieren" bestätigst Du, dass Du alle Geo-Daten unter der Lizenz ODbL für OpenSeaMap und Openstreetmap weltweit allen zur Verfügung stellst.

Unmittelbar nach dem Klick auf "Registrieren" bekommst Du eine Bestätigungsmail an die angegebene Mailadresse. Klicke dort auf den im Text angegebenen Link und bestätige damit, dass Du derjenige bist, der dieses Benutzerkonto angelegt hat. Du wirst sofort freigeschaltet und kannst jetzt den Editor benutzen.

Passwort vergessen

Wenn Du Dein Passwort vergessen hast, kannst Du es Dir per Mail zuschicken lassen. Gehe dazu unter Openstreetmap.org auf "Anmelden" und klicke auf den Link "Passwort vergessen?". Gib Dort Deine Mailadresse ein, mit der Du Dich angemeldet hast. Dein altes Passwort wird dann zurückgesetzt und Du bekommst an die angegebene Mailadresse einen Link zugeschickt, über den Du ein neues Passwort wählen kannst. Das funktioniert natürlich nur, wenn Du auch im Ausland Deine Mails von der Mailadresse unter der Du bei OpenSeaMap angemeldet bist auch abrufen kannst.

JOSM aktualisieren

Auf der Startseite von JOSM erscheint die Nachricht "Aktualisieren", wenn eine neue Version vorliegt. Ein Klick auf den Link öffnet die JOSM-Wiki-Seite. Lade dort die aktuelle JOSM-tested.jar herunter. Sie liegt dann im "Download"-Ordner und muss dann im Explorer kopiert und im richtigen Ordner eingefügt werden (meist "C:\Programme\JOSM\").

Der "SeaMapEditor" und die dazugehörigen Icons werden automatisch aktualisiert.